-->
Results 1 to 8 of 8

Thread: New to the forum...

  1. #1
    Registered User
    Name: Marc


    Join Date
    Jul 2020
    Posts
    3

    New to the forum...

    So every search sends me here... recently brought home my dad's 1993 lightning (red). He bought it new my senior year of high school. He finally decided to let her go and knew I've always wanted her. Hasnt run in what i can guess 6 yrs. Already started the process of routine maintenance. Mouse removal was a good place to begin. She had a powerdyne SC on it years ago but has since been removed. I have a million questions but will work my way through the forums to try to find answers. This will be a fun journey for my two boys and I to get her back on the road.

  2. #2
    Make NLOC Great Again
    Name: Raymond

    Raymond_B's Avatar
    Join Date
    Sep 2000
    Location
    Texas
    Posts
    5,765
    Quote Originally Posted by Eden2020 View Post
    So every search sends me here... recently brought home my dad's 1993 lightning (red). He bought it new my senior year of high school. He finally decided to let her go and knew I've always wanted her. Hasnt run in what i can guess 6 yrs. Already started the process of routine maintenance. Mouse removal was a good place to begin. She had a powerdyne SC on it years ago but has since been removed. I have a million questions but will work my way through the forums to try to find answers. This will be a fun journey for my two boys and I to get her back on the road.
    Welcome, as someone who just got his Lightning back on the road after almost 20 years I can certainly relate!

    Take pictures of the good the bad the mouse poop etc. We all love to see a Lightning coming back to life.
    1995 Black #2127
    427w, Novi 2000, and a lot of stuff
    http://www.buildpics.org/

    Find the NLOC on Facebook
    https://www.facebook.com/nloc.net/

  3. #3
    Registered User
    Name:


    Join Date
    Dec 2008
    Posts
    503
    welcome to the forum Marc.

  4. #4
    Registered User
    Name: Marc


    Join Date
    Jul 2020
    Posts
    3
    Thanks for the welcome.. been taking pics as we go. Trying to reverse engineer what's been done. She'll fire, but stalls immediately. Cant imagine anything major. 61k original miles. No accidents. Just scratches and dings. Been garage kept but paint is faded. No rust to speak up, had an undercoating sprayed early on. So far only made it through new battery, new serp, cleaned out intake, drained gas, new fuel filter, cleaned out exhaust, oil change, and pulled the PCM to see whats in it. There was an extra in the parts boxes so I knew it was swapped. Now to figure out if I should swap it back or not.. and so it begins.

  5. #5
    Registered User
    Name: Gary

    BlackFlareSide's Avatar
    Join Date
    Jan 2020
    Location
    Okeechobee, FL
    Posts
    212
    Has it been converted to Mass air? That could be the reason for the ecm swap.


    Sent from my iPad using Tapatalk

  6. #6
    Registered User
    Name: Marc


    Join Date
    Jul 2020
    Posts
    3
    Yes.. my dad swapped over to Mass air, injectors, etc.. but after pulling the SC he pulled the injectors back out, and I think all the SC related parts. I plan to take her back to stock minus the headers and exhaust so I can sort out why shes not running right. I can swap it back later.. between the SC install and removal, and the Ford Mass Air conversion kit I have a number near if things to sort out. First is to figure out what should be on it in stick trim.

  7. #7
    Registered User
    Name: Gary

    BlackFlareSide's Avatar
    Join Date
    Jan 2020
    Location
    Okeechobee, FL
    Posts
    212
    Is there a stock wiring harnesses in the parts box? Or did he modify the stock harness for the MAF?


    Sent from my iPhone using Tapatalk

  8. #8
    Born Ignorant
    Name: Jim

    IVSVS's Avatar
    Join Date
    Mar 2008
    Location
    Lancaster Pa
    Posts
    6,335
    Congrats and welcome to the group! Lots of pictures are required.
    When and if you ever put a signature up with your mods in it, make sure you include the mouse poop in it. If you hang out here long enough you'll find out the inside joke.

    - - - Updated - - -

    Quote Originally Posted by Eden2020 View Post
    Yes.. my dad swapped over to Mass air, injectors, etc.. but after pulling the SC he pulled the injectors back out, and I think all the SC related parts. I plan to take her back to stock minus the headers and exhaust so I can sort out why shes not running right. I can swap it back later.. between the SC install and removal, and the Ford Mass Air conversion kit I have a number near if things to sort out. First is to figure out what should be on it in stick trim.
    More than likely, the mass air meter is calibrated for the bigger injectors, thus why it won't run. If you still have his injectors, throw them in and see what happens.
    LoudMouth Motors Team Member

    "Of course its fast. It has a Lightning Bolt on it."

    Born 7/12/93 #4910
    Punisher Street VB, Mark VIII Fan, 130 amp alt and Struckby Wiring for the following: E-fan, Battery Cables and 3 Pump Trick. Eaton TruTrack, JLP Longbars with Gen-1 shortened rear brackets, Bassani catted midpipes, 2.5" Magnaflows on stock cat-back, Bilsteins on all 4 corners, Walbro 255 pump, 10:1 FMU, Circle-D 2800 Triple-Disc Converter, Cobra roller cam, Crane 1.7 Roller Rockers, MSD BTM ignition, 8" Renegade lower pulley, 3.15" pulley on a Vortech S-Trim, BBK 1-5/8" headers. 1" Snakebit intake spacer, 4" intake piping, Autometer gauges. 110 purple VP fuel, DJM Dream Beams, Belltech drop hangars and shackles. CGM Motorsports prepared GT40 heads.

    12.376@109.26 untuned
    12.0 or I join Ed in the Dumpster....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •