-->
Results 1 to 14 of 14

Thread: Looking for an ECU

  1. #1
    Registered User
    Name: Patrick


    Join Date
    Sep 2019
    Posts
    18

    Looking for an ECU

    I have a 1994 with C3P3 and am having shifting issues with my transmission. The trans is fresh and have troubleshot down to the ECU. Looking for an ECU or even a little more guidance as to what to do. My ECU had water penetration, the nuetral safety switch was froze and changed it, speedometer works fine.

  2. #2
    Registered User
    Name: Rick


    Join Date
    Feb 2020
    Location
    Canyon,tx
    Posts
    64

    Looking for an ECU

    My shifting was harsh and I had idle trouble. Pulled my ECM and removed the top to find leaking capacitors. I would do that, as you can replace them very cheaply yourself with a soldering gun.


    Sent from my iPhone using Tapatalk

  3. #3
    Registered User
    Name:


    Join Date
    Dec 2008
    Posts
    486
    check the PCM (ECU) for DTC (diagnostic trouble codes). some trans codes can show up there among others.

  4. #4
    Registered User
    Name: Patrick


    Join Date
    Sep 2019
    Posts
    18
    There are no codes as of right now and I already replaced the capacitors.

  5. #5
    Make NLOC Great Again
    Name: Raymond

    Raymond_B's Avatar
    Join Date
    Sep 2000
    Location
    Texas
    Posts
    5,716
    Quote Originally Posted by Pricepc85 View Post
    There are no codes as of right now and I already replaced the capacitors.
    Did it run OK before you swapped the transmission?

    How many capacitors were blown that you had to replace?
    1995 Black #2127
    427w, Novi 2000, and a lot of stuff
    http://www.buildpics.org/

    Find the NLOC on Facebook
    https://www.facebook.com/nloc.net/

  6. #6
    Registered User
    Name: Patrick


    Join Date
    Sep 2019
    Posts
    18
    The transmission was swapped by the previous owner, it has ran in limp.mode since I bought it. I replaced 3 or capacitors.

  7. #7
    Registered User
    Name: Patrick


    Join Date
    Sep 2019
    Posts
    18
    I think 2 were bad and I replaced all of the ones i could while i was already doing the work. Since replacing the capacitors, it runs a little smoother and idles better, but the trans remains the same.

  8. #8
    Vrrooooooooooom
    Name: Jeff

    FMOS Racing's Avatar
    Join Date
    Jan 2000
    Location
    Raleigh, NC
    Posts
    13,457
    Can you elaborate on "shifting issues"?
    #72 in 1995, Crimson
    Tweaked and Turbocharged
    10.81@126.7

  9. #9
    Stroked & Blown
    Name: Billy D.

    lightning_2000's Avatar
    Join Date
    Apr 2005
    Location
    McMinnville, Tn
    Posts
    7,171
    I have a ecu

    Sent from my SM-G975U using Tapatalk
    1.51 6.55 @ 107.9 14 psi

    393w s484
    Chris Garrett e4od

  10. #10
    Registered User
    Name: Patrick


    Join Date
    Sep 2019
    Posts
    18
    I PMed you lightning_2000.

  11. #11
    Registered User
    Name: Patrick


    Join Date
    Sep 2019
    Posts
    18
    When shifting from park to drive, it starts out in second. It only starts in first when manually shifted to first. When put into reverse, it's a hard shift into reverse.

  12. #12
    Stroked & Blown
    Name: Billy D.

    lightning_2000's Avatar
    Join Date
    Apr 2005
    Location
    McMinnville, Tn
    Posts
    7,171
    I had a white 95

    Went thru everything on it


    Bad ecu was its issue

    I never read another person having the same issue



    Mine would hit over drive by 35mph.


    Just hit all shifts quickly. Swapped computer. Was mint

    Sent from my SM-G975U using Tapatalk
    1.51 6.55 @ 107.9 14 psi

    393w s484
    Chris Garrett e4od

  13. #13
    Registered User
    Name: Patrick


    Join Date
    Sep 2019
    Posts
    18
    How much do you want for your ECU?

  14. #14
    Registered User
    Name: John


    Join Date
    Feb 2007
    Location
    So Cal
    Posts
    17
    I had the same problem. Something quick to try, unplug the antilock brake module behind passenger kick panel. Something about it disrupting vss signal to computer. Unplugging it has no other effect other than loss of antilock assist that only is applied to rear brakes anyway.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •